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Basic Workflow
In a collaborative Model-Driven Development (MDD) environment, software
run-time errors can be produced by either design issues in the model or faulty
handwritten code. You may be able to detect the flaws using code reviews
and intensive testing. However, these techniques are time-consuming and
expensive.

Through Polyspace® UML Link™ RH software, you can apply Polyspace
verification to C, C++ and Ada code that you generate from your IBM®

Rational® Rhapsody® model. As a result, you can detect run-time errors
and automatically identify model flaws quickly and early during the design
process.

For information about installing and using IBM Rational Rhapsody, go to
www-01.ibm.com/software/awdtools/rhapsody/.

The workflow for using the Polyspace UML Link RH add-in within the IBM
Rational Rhapsody MDD environment is:

• Install the add-in. See “Installing Polyspace UML Link RH Product” in
the Polyspace Installation Guide.

• Integrate the Polyspace add-in with your Rhapsody project. See “Adding
Polyspace Profile to Model” on page 1-6.

• If required, specify Polyspace configuration options in the Polyspace
verification environment. See “Configuring Verification Options” on page
1-8.

• Specify the include path to your operating system (environment) header
files and run verification. See “Running a Verification” on page 1-11 and
“Monitoring a Verification” on page 1-13.

• View results, analyze errors, and locate faulty code within model. See
“Viewing Polyspace Results” on page 1-14 and “Locating Faulty Code in
Rhapsody Model” on page 1-16.
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Accessing Polyspace Features

Accessing Polyspace Features
To access Polyspace features in the Rhapsody editor:

1 Open the model that you want to verify. For
example, psdemos_uml_link_airbag.rpy in
Polyspace_Common/PolyspaceUMLLink/psdemos. Polyspace_Common is
the installation location of the Polyspace common folder.

2 In the Entire Model View, expand the Packages node.

3 Right-click a package, for example, AirBagFiles.
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You see the following Polyspace functions in the context menu:
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Accessing Polyspace Features

• Polyspace Verification — Start verification. See “Running a
Verification” on page 1-11.

• Polyspace Help — Open help.

• Stop Polyspace Verification — Stop client-based verification. See
“Running a Verification” on page 1-11.

• Polyspace Spooler — Open Polyspace Queue Manager. See
“Monitoring a Verification” on page 1-13.

• Edit Configuration — Specify verification options. See “Configuring
Verification Options” on page 1-8.

• View Results — View verification results. See “Viewing Polyspace
Results” on page 1-14.

Note You must add the Polyspace profile to your model before you try
to access Polyspace functions. See “Adding Polyspace Profile to Model”
on page 1-6.
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Adding Polyspace Profile to Model

In this section...

You must add the Polyspace profile to your model before you try to access
Polyspace functions:

1 In the Rhapsody editor, select File > Add Profile to Model. The Add
Profile to Model dialog box opens.

2 Navigate to the folder
Polyspace_Common/PolyspaceUMLLink/profiles/Polyspace.

3 Select the file Polyspace.sbs. Then click Open.

Now, if you right-click a package or file, you see Polyspace functions in the
context menu.
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Polyspace Verification is also available from the Tools menu.
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Configuring Verification Options
To specify options for your verification:

1 In the Entire Model View, right-click a package or class, for example,
AirbagControl.

2 From the context menu, select Edit Configuration. The Configuration
pane of the Polyspace verification environment opens.

1-8



Configuring Verification Options

3 Select options for your verification. In particular, you must specify the
following:

• Target operating system (-OS-target)

• Dialect (-dialect)

• Include Folders (-I) — Path to your operating system (environment)
header files.

Note Polyspace provides Linux® header files for C++ in include-gnu,
which is located within the Polyspace product folder. For example,

C:\Polyspace\PolyspaceForCandCPP_R2011b\Verifier\include\include-gnu

4 To save your options, in the top left corner, click the disk button.

For information on how to choose your options, see:

• “Option Descriptions” in the Polyspace Products for Ada Reference.

1-9



1 Polyspace® UML Link™ RH User’s Guide

• “Option Descriptions for C Code” and “Option Descriptions for C++ Code”
in the Polyspace Products for C/C++ Reference.
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Running a Verification

Running a Verification
To start a verification:

1 In the Rhapsody editor, select Tools > Polyspace Verification. The
software opens the Polyspace Verification dialog box.

Note Before starting a verification, make sure that the generated code
for the model is up to date.

2 In the Results folder field, specify a location for your verification results.

3 Select the Verification mode:

• Class— Select a specific class from the Class to verify drop-down list.
In addition, underVerify with (highlight classes), you can select other
classes from the displayed list, for example, CrashSensor_C.
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• Expert— The software verifies code according to the Generate a main
(-main-generator) options that you specify.

4 If you want to run the verification on your Polyspace server, select Send to
Polyspace server.

5 Click Run. You see verification messages on the Log tab of the Rhapsody
editor.

If your verification is client-based, you can stop your verification. In the
Entire Model View, right-click, for example, a package or a class. From the
context menu, select Stop Polyspace Verification.

To stop a verification on the Polyspace Server, use the Polyspace Queue
Manager. See “Monitoring a Verification” on page 1-13.
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Monitoring a Verification
If your verification is client-based, you can observe progress on the Log tab of
the Rhapsody editor.

If your verification is running on a Polyspace Server, in the Entire Model
View, right-click, for example, a package or a class. From the context menu,
select Polyspace Spooler to display the Polyspace Queue Manager (or
Spooler). Use the Polyspace Queue Manager to manage jobs running on any
Polyspace Server.

For more information, see:

• “Managing Verification Jobs Using Polyspace Queue Manager” in the
Polyspace Products for Ada User’s Guide

• “Managing Verification Jobs Using the Polyspace Queue Manager” in the
Polyspace Products for C/C++ User’s Guide
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Viewing Polyspace Results
To view results from the last completed verification, in the Entire Model
View, right-click, for example, a package or a class. From the context
menu, select View Results. The Polyspace verification environment opens,
displaying results in the Run-Time Checks perspective.

For more information on Polyspace verification results, see:

• “Reviewing Verification Results” in the Polyspace Products for Ada User’s
Guide

• “Reviewing Verification Results” in the Polyspace Products for C/C++
User’s Guide
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Declarations for C Functions Without Arguments
By default, Rhapsody generates declarations for functions without any
parameters, using the form:

void my_function()

rather than:

void my_function(void)

This can result in the following Polyspace compilation error:

Fatal error: function 'my_function' has unknown prototype.

To avoid this problem, in Rhapsody, at the project level, set the property
C_CG::Configuration::EmptyArgumentListName to void.
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Locating Faulty Code in Rhapsody Model
To identify the faulty code within your Rhapsody model using Polyspace
verification results:

1 In the Run-Time Checks perspective of the Polyspace verification
environment, navigate to an error, for example, a non-initialized variable
at line 102 of Airbag Control_C.

2 In the Source pane, right-click the error. From the context menu, select
Back to model.

Note For the Back To Model command to work, you must have your
Rhapsody model open.

The Back To Model command is available only if the Polyspace check is
enclosed by the tags //#[ and ]#//.
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Locating Faulty Code in Rhapsody Model

The software locates the faulty code within your Rhapsody model.
Depending on the Rhapsody configuration, the faulty code appears either
in a dialog box or in the code view.

Limitations
If a source code line containing a macro produces a Polyspace check, you
cannot use the Back to Model command to go to the code. Use the following
workaround:

1 From the Polyspace verification environment, select
Options > Preferences to open the Polyspace Preferences
dialog box.

2 Select the Editors tab.

3 In the Text Editor field, enter
Polyspace_Common/PolyspaceUMLLink/bin/BackToModel_version_number.exe.

4 For Arguments:

• From the drop-down list, select Custom.
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• In the text field, specify $FILE $LINE.

5 Click OK.

Now, to go to the code, right-click the check and select Open Source File
from the context-menu.

For locations where Rhapsody does not support the Back to Model command,
or for code that does not belong to the model, the software produces the
following warning when you try to use the Back to Model command:

No element found in model
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Template Configuration Files

In this section...

“Using Template Configuration Files” on page 1-19

“Default Configuration Options” on page 1-19

Using Template Configuration Files
The first time you perform a verification, the software
copies a template, Polyspace configuration file, from
Polyspace_Common/PolyspaceUMLLink/etc/template_language.cfg to the
project folder. The software also renames the copy model_language.cfg,
where:

• model is the name of your model

• language is the name of the language that the model targets, that is, C,
C++, or ADA

You can update the template .cfg file by one of the following means:

• Editing it through the Polyspace verification environment

• Double-clicking the file in a Windows® Explorer window

• Replacing the template file with a copy of the .cfg file from a Rhapsody
model folder

You can then share a configuration among project members and use the
configuration with other projects.

Default Configuration Options
The template_language.cfg XML files specify the default option values
for code verification.

The file template_Ada.cfg is:

<?xml version="1.0" encoding="UTF-8"?>

<polyspace_project name="template_cfg" language="Ada 95" author="polyspace"

1-19



1 Polyspace® UML Link™ RH User’s Guide

version="1.0" date="08/04/2011" path="file:/C:/Polyspace/Polyspace_Common

/Rhapsody/PolyspaceUMLLink/etc/template_ADA.cfg">

<source>

</source>

<include>

</include>

<module name="Verification_1" isactive="true">

<source>

</source>

<optionset name="template_cfg" isactive="true">

<option flagname="-OS-target">no-predefined-OS</option>

</optionset>

</module>

</polyspace_project>

The file template_C.cfg is:

<?xml version="1.0" encoding="UTF-8"?>

<polyspace_project name="template_cfg" language="C" author="polyspace"

version="1.0" date="08/04/2011" path="file:/C:/Polyspace/Polyspace_Common

/Rhapsody/PolyspaceUMLLink/etc/template_C.cfg">

<source>

</source>

<include>

</include>

<module name="Verification_1" isactive="true">

<source>

</source>

<optionset name="template_cfg" isactive="true">

<option flagname="-OS-target">no-predefined-OS</option>

<option flagname="-allow-undef-variables">true</option>

<option flagname="-respect-types-in-fields">true</option>

<option flagname="-respect-types-in-globals">true</option>

</optionset>

</module>

</polyspace_project>

The file template_C++.cfg is:

<?xml version="1.0" encoding="UTF-8"?>

<polyspace_project name="template_cfg" language="C++" author="polyspace"
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version="1.0" date="08/04/2011" path="file:/C:/Polyspace/Polyspace_Common

/Rhapsody/PolyspaceUMLLink/etc/template_C++.cfg">

<source>

</source>

<include>

</include>

<module name="Verification_1" isactive="true">

<source>

</source>

<optionset name="template_cfg" isactive="true">

<option flagname="-D">[OM_NO_FRAMEWORK_MEMORY_MANAGER]</option>

<option flagname="-OS-target">no-predefined-OS</option>

<option flagname="-allow-undef-variables">true</option>

<option flagname="-dialect">gnu</option>

<option flagname="-respect-types-in-fields">true</option>

<option flagname="-respect-types-in-globals">true</option>

<option flagname="-target">i386</option>

</optionset>

</module>

</polyspace_project>
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